Back to overview
Degraded
We are facing some issues with integrations
May 30, 2025 at 01:10pm UTC
Affected services
APIs
Resolved
May 31, 2025 at 04:09am UTC
The issue with integration has now been resolved. Some syncs across integrations platforms may have been affected during this time period.
Affected services
Created
May 30, 2025 at 01:10pm UTC
Due to some issues, our integrations are temporarily down. Our team is working on a fix and will update soon.
Affected services