Back to overview
Degraded
We're noticing some delays in sending messages. Our team is working on a fix.
Mar 14 at 11:56am IST
Affected services
Periskope Console
Resolved
Mar 14 at 12:20pm IST
This issue is now resolved. Please let us know if you still face issues in sending messages on Periskope.
Affected services
Created
Mar 14 at 11:56am IST
We're noticing some delays in sending messages. Our team is working on a fix. You will be updated as soon as this issue is fixed.
Affected services