Back to overview
Downtime

Some phones may be disconnected during our maintenance. Please reconnect.

Jan 30 at 11:30am IST
Affected services
Periskope Console

Resolved
Jan 30 at 08:18pm IST

Our services back online. You should be able to connect your phones to Periskope and resume your operations. Please let us know if you are still facing any issues with Periskope.

Created
Jan 30 at 11:30am IST

We're seeing some issues on Meta's side and are performing emergency maintenance. Service may be temporarily down – we’ll be back with an update shortly.