Back to overview
Degraded
Services are temporarily degraded.
Jun 22, 2026 at 6:55am UTC
Affected services
Periskope Console
Chats & Tickets
Analytics
Resolved
Jun 22, 2026 at 7:08am UTC
This incident has been resolved now.
Affected services
Created
Jun 22, 2026 at 6:55am UTC
We're currently experiencing high database load, which is causing delays in loading the application. Our team is actively investigating the issue.
Affected services