Back to overview
Degraded

Global AWS outage

Oct 20 at 02:45pm IST
Affected services
Periskope Console
APIs

Resolved
Oct 20 at 03:48pm IST

The situation is now resolved and we are monitoring the situation

Created
Oct 20 at 02:45pm IST

A global outage with AWS has affected multiple providers globally. You can experience delays or issues in login, billing and comms.

Our team is monitoring the issue