Back to overview
Degraded

Messages are failing to be delivered or decrypted

Aug 04, 2025 at 10:01am UTC
Affected services
Periskope Console

Resolved
Aug 06, 2025 at 06:26pm UTC

We've deployed a fix and are monitoring it

Updated
Aug 06, 2025 at 05:40am UTC

We are still getting reports of delivery on some devices sporadically. Our team is working with external teams to diagnose and fix this

Updated
Aug 06, 2025 at 02:22am UTC

Message delivery issues have dropped significantly now. We will fail messages that do not receive an acknowledgement for more than 5 seconds

Updated
Aug 05, 2025 at 03:51pm UTC

We have pushed a fix and are monitoring delivery rates

Updated
Aug 05, 2025 at 10:03am UTC

As a temporary measure, we are now marking messages as errored (where we do not receive a delivery acknowledgement within a few seconds)

We are working on a fix with external teams here

Created
Aug 04, 2025 at 10:01am UTC

We are observing some issues in delivery of messages. It may show up as -
"Waiting for this message" on some recipient devices

This is due to a migration by Meta over the weekend. Our team is working to identify the root cause and fix this